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Introduction to Igor

There are many data analysis packages available on every computer platform (Mac, Win-
dows, Unix, etc.). One of the more common ones found in professional and graduate
research labs is called Igor, made by Wavemetrics. Early versions of Igor mostly employed
powerful command-line instructions and outstanding control and precision of the graphics.
Another attractive feature was a flexible programming/scripting environment which made
it very easy to create complex analysis procedures. However, this format was not well
suited for teaching labs. Getting started was tough and it took a lot of time to develop a
practical skill with Igor. Now, the software is much more user friendly but the backbone of
a sophisticated data analysis package remains. The program can be used for simple tasks
like displaying introductory lab data in a few simple steps and to a high level interface
with a complex experimental apparatus (see the Wavemetrics website for screenshots).

1 Command Line Basics

When you first start Igor, the default appearance is a Command Window, with the self-
denying title “Untitled”, and an empty Table Window called “Table0”.
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The Command Window has two parts, a command entry bar at the bottom and a history
box to display previous operations (not just typed-in commands, many mouse clicks result
in an entry). This is great for people who would rather type commands than point-and-
click a mouse. The history display is very handy for looking over a series of steps in data
analysis or for calling up and executing a previously typed command (use up-arrow and
down-arrow keys to navigate and hit enter to copy into the command bar). When you save
an Igor “Experiment” (as it is called), the history is saved along with data, procedures,
functions, programs, et cetera.

You can do a lot with commands, such as the example below where I create x and y data
arrays, calculate the function y = e−x/10 sin(2πx) for the range 0 ≤ x ≤ 10, and plot it.

Exercise: The figure shows a sequence of commands

make/n=100 xdata, ydata
xdata = x/10
append xdata, ydata
ydata = exp(-xdata/2)*sin(2*pi*xdata)
display ydata vs xdata
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The “append” command operates on the “top most“ window, in this case Table0 - it
adds elements to the table. If a graph window is selected, the append command adds plots
to the graph. One of the menus that appear at the top of the screen will also change
depending on which window is selected. In other words, tables, graphs, and layouts will
have different options available, which makes sense. Try clicking on the Graph and Ta-
ble windows to see which menu changes. Select the Graph window and try the append
command.

Note that the “ydata = exp ...” command calculates the entire array in one command, a
lot like Matlab. Try changing the function (click on the command and hit enter and the
command will be automatically typed into the command entry box - you can edit it and
hit enter again to execute the new command).

2 Table and Graphing Basics

Igor also has an intuitive graphical user interface for basic data entry and graphing. The
Table Window can be used to enter data manually, cut and paste data from other programs,
and display data that was read from a file or created from a function. Once data is entered,
a new graph can be made by selecting the menu item Windows→New Graph.

The data shown below was taken during a Cavendish lab where the data was entered by
hand, displayed, and later fit to general function for a damped harmonic oscillator. As
data is typed or pasted into Igor, the default names are given, wave0, wave1, wave2, etc.
(if preferred, these names can be changed with the Rename operation). In this case, wave0
is the time in seconds, wave1 and wave2 are the measured positions of a laser beam on a
wall. In the experiment, the laser beam was reflected off a mirror attached to torsional
oscillator and is related to rotation angle.
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Data Plot Exercise: To save time, a data file is provided and can be opened in a text editor,
copied, and pasted.

• Open the file “Cavendish.txt” in a text editor.

• Select and copy the first column of data (time).

• In Igor, start a new experiment.

• In the Table0 window, click on the top row of the first column and paste.

• The column title should become “wave0”.

• Repeat for the next two columns of data (positions for two configurations of the lead
balls)

• To graph these data, choose the Windows→New Graph menu item. A box will show
up with two lists, a Y Wave and an X Wave list.

• Choose “wave1” for the Y Wave and shift-click on “wave2” to select two. Select
“wave0” for the X-Wave (if you leave “ calculated ” as the X Wave then the x-axis
is simply the data number 0, 1, 2, 3, and so on)

• Click on “Do It” and the data should be displayed.
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3 Curve Fitting Basics

The Cavendish lab measures a very small shift in position of a torsion balance oscillator
in the presence of 1 kg lead balls. This shift corresponds to a change in position of the
reflected laser beam of about 1 cm. It is more accurate to measure the “center” of damped
harmonic motion of the torsion balance because the displacements from the center are large
compared to the uncertainty of each measurement. We’ll use curve fitting to extract this
datum.

The Curve Fitting dialog box offers a lot of control. I won’t pontificate about the care one
must take in this business, but students can develop some really bad habits. Software that
makes this too easy might be part of the blame. I think the curve fitting package in Igor
is professional and robust.

Curve Fitting Exercise: This figure shows the first pane of the Curve Fitting dialog box,
where you select the Y and X arrays and the fitting function. You can define your own
function, too, which brings up a function definition dialog box.

• Select the graph window and then choose the Analysis→Curvefit menu item.

• The Curve Fitting dialog box opens. Select the leftmost tab near the top of the
dialog box labeled “Function and Data”.

• Choose “wave1” for Y Data and “wave0” for X Data.
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• Browse the functions and notice that the function definition appears in the equation
box.

• In this example, we should fit to a damped harmonic oscillator function, which is not
on the list. This requires a new function definition.

• Click on a New Fit Function.

• Make up a name, set up 5 Fit Coefficients (A, B, C, D, E, each in its own box), an
Independent Variable (t), and type in the function A + B*exp(-C*t )*sin(D*t + E).

• Click on the Coefficients Tab near the top of the dialog box and make estimates of
the coefficients.

• Before clicking “Do It”, click on the “Output Options” tab. This dialog allows one
to control the whereabouts of the calculated function that best fits the data.

• Choose “ New Wave ” and call is something reasonable, such as “wave1Fit”.

• Double check all of the settings and then “Do It”.

If all goes well, your fitting parameters for the best fit will appear in the command win-
dow. The fitted function is not automatically displayed unless you use the auto feature
in the ‘Output Options”, but it is easy to add another trace to the display, just chose the
Graph→Append Traces to Graphic menu item, choose “wave1Fit” for the Y Wave(s), and
“wave0” for the X Wave.

Save the experiment with your name in the title and re-open it (double click on the
file or choose the File→Open menu item). Notice that all of the commands that you
executed are done over. The history of commands regenerates the graphs, curve-fits, and
modifications.

4 Layout Basics

Layouts are used to make neat and informative printouts, excellent fodder for lab books.
I find it especially useful to combine the graph of fitted data with the fitting function
equation and the results of the curve fit that are displayed in the history. Too many
times have I found curve fit data with no information about the fitting function, fitted
parameters, or statistical uncertainties.
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Layout Exercise: Open the file that was saved in the last exercise.

• Choose the Window→New Layout menu item.

• Select “Graph0” and click “Do it” to open the Layout0 window.

• Notice the toolbar on the left side of the window. To add text to the layout, click on
the A... button and click somewhere in the layout area.

• A dialog box opens with many options. Most instances, I only enter text or paste
text from the history window, such as the results of a curve fit.

• There are lots of bells and whistles that I ignore, but font, size, and position control
are pretty to have.

• Be sure to un-select the A... button by clicking on the arrow button, otherwise you
keep making text boxes.

5 Data Import Basics

There are some pretty crazy data formats out there. I’ve had the most success using Igor
to find data embedded in text and it’s especially useful if you have many data files with the
same structure (for example, the x-y numbers always start on line 17). Once you figure out
how Igor can read a file, the process can be automated in a script to read a whole folder
full of files. To get started, the following exercise uses two methods to extract correlation
data from a file that has text and four different types of data blocks. The first method
uses a dialog box to find the data from a file. The second method starts with a dialog box
to perform the same operation but saves it as a command. This command can be copied
into a script, called a macro, to open any file of the same format and similar file name.
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The data file starts with some header information followed by a block of 3-column data, a
few lines of text, a block of 8-column data, text, a block of 3-column data, text, and finally
two columns of data. The correlation data that we want to extract is in the first block.
The first column is delay time, second column is the correlation function between detector
1 and detector 2 and the second column is vise versa.

Data Import Exercise: Method I

• Choose the Data→Load Waves→Load General Text menu item.

• Select the data file “alexa 10s 1.SIN” from the workshop files.
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• Notice that Igor immediately skips the non-numerical text and recognizes that there
are three columns in the first block of data.

• These are the data that we want, but don’t load them for the moment. See what
happens when you click on the “Skip this block” button.

• Since we missed our data, cancel the import and start again, this time loading the
first set of data (three columns of two-detector correlation data).

• Quit the import since we don’t want to load the other data blocks.

• Notice in the history there is information about which line the data was found. No
column names were found on line 15, which means that the data starts on line 16.
Also, there are 608 lines of data in the first block. This is easily checked by listing
the data in Table0 (either use the “append” command or the Table menu).

Data Import Exercise: Method II

• Choose the Data→Load Waves→Load Waves menu item (yes, there menu items have
the same name!)

• Choose General Text from the pull down menu near the top of the Load Waves dialog
box.

• Click on File... button and once again select the data file “Alexa 10s 1.SIN” from
the workshop files.
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• This time click on “To Cmd Line”. The import operation is not executed yet. The
command line equivalent is entered into the command line. We can edit it and then
execute the command by hitting return. But first let’s make some changes.

• For some reason, this procedure skips the first and last data rows of data, so change
the command line text from 17 to 16, and from 607 to 608.

• To see what all of the slash-letter specifications (command flags) do, go to the
Help→Igor Help Browser menu item and click on the “Commands” tab near the
top of the dialog box. You’ll see an alphabetical list of commands on the left, scroll
down to the “LoadWave” command.

• If you execute the LoadWave command, Igor will open a dialog box asking for names
for the waves. We don’t want this if we are going to automate the process. Add the
“/A” flag to the “LoadWave”, I don’t think it matters which order the flags are put
into the command.

• Hit return to execute the command. The history should show that data was loaded
into wave3, wave4, and wave5.

• Lastly, we can display the correlation data in a graph of wave1 or wave 2 vs wave0.
It doesn’t look like much unless you change the plot to a semi-log plot. Choose the
Graph→Modify Axis menu item and select “bottom” from the pull down menu

6 Creating Macro and Functions

Following from the last section, the next logical step is to automate the procedure of opening
a data file, extracting the numerical data, assigning each array a specific name, and finally
plotting them. Igor uses the Procedure Window for the development of Macros as well as
functions and programs. This window can be opened from the Windows→Procedures→Procedure
menu item (or cmd-M on the Mac). The format for making Macros and passing string data
is presented in the exercise.

The data set names that we imported in the last section had a base name, followed by an
integer running from 1 to the last file of the run, and a file extension .SIN. The base name
is “alexa 10s ” and the integer index runs from 1 to 10 (usually it runs up to 30 or 40). If
we are to load all ten data sets, it will be hard to keep track of data types if we use the
default “wave0, wave1, ...” scheme. A better scheme is to set the array names to “AC1 0”,
“AC1 1”, and “AC1 2” for the first set, “AC2 0”, “AC2 1”, and “AC2 2” for the second,
and so on. This will be one of the tasks of our macro.
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Exercise: Create a Macro to read data and display it with one command.

• In the Procedure Window, a macro definition starts with the line

Macro mName(parameter list)

and ends with “End”. In between are commands and variable definitions. You can
choose a name that makes sense, for example, LoadDisplay is the name I chose in
the figure. There can be as many as 10 parameters in the list.

• The next line in the macro must define the parameter data types. In our case, we’ll
be passing part of the filename, so it will be a string variable: “String name” is the
format for the definition (you can call it whatever you want as long as it doesn’t have
some other meaning in Igor).

• We need to define some local variables for the macro which we’ll use to compose the
filename and the array names. Define the string variables “fName” for the data file
name, “wName” for the base name of array names, and “wName0”, “wName1” for
the display command. It seems that each variable needs its own definition line, as
shown in the figure.

• String manipulation is really easy in Igor, strings can be concatenated with a “+”
sign. For example, the code
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fName = “alexa 10s ” + name + “.SIN”

will result in assigning fName to the string “alexa 10s 1.SIN” if “name” is the string
“1”, “alexa 10s 2.SIN” if “name” is the string “2” and so on. When we use this
macro, setting the input parameter to the string “n” will call up nth data file.

• Once the string names are constructed, use the command that we formed in the last
section

LoadWave/G/D/L={0,17,607,0,3}/A=$wName/O fName

Notice the “$” character before the wName string. This forces a conversion from
string to the name of a command element. Commands expect specific data types or
names of data, and in this instance the “$” converts a string to a name of a data
array. The filename parameter should be a string, so we don’t need to convert fName
to a string, it is already a string.

• Finally, once the data is imported, we plot and set the horizontal axis to a log scale.

• To use the macro, type into the command window

LoadDisplay(”5”)

Exercise: Define a Function

Similar to a macro, functions can be defined in the Procedure Window and are executed in
the command window. But, as the name implies, functions return a value. Like in Matlab,
If one of the function parameters is a wave, then it returns a wave. The following example
generates two functions. One calculated the ordinary refractive index of BBO as a function
of wavelength (in microns) and the other calculates the extraordinary refractive index of
BBO as a function of wavelength and polar angle to the optic axis of the propagation
direction. A plot is generated from these functions which gives the angle tuned phase
matching condition for Type I collinear phase matching of parametric downconversion
(0.405 µm pump).
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• The first line in the function definition is

Function nExtraordinary(lam,theta)

and it ends with “End”. Like before, the parameters must be declared at the start
of the function.

• Functions must return a value with the line

return(dataCalc)

• Within the function, all of the usual programming structures are available: if-else-
endif, for-endfor, do-while, switch-case-endswitch (like case in C).

• Igor will compile the function when you click on another window. If there is some
syntax error, you will get an alert. One can also click on the Compile button at the
bottom of the Procedure Window to compile the function and check for any errors.

• Once compiled, the function can be called from the Command Window and also from
other functions. Like in Matlab, whole arrays can be calculated in one commend using
a function. The example shown in the figure calculates the array of n-values from an
array of angles

n = nExtraordinary(0.81,theta)
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